I tried configuring MP-BGP between R1 and R5 using the link-local addresses but the BGP does not come up. I don't understand why.
I have frame-relay maps for the link-local addresses. I used the update-source specifying the frame-relay interfaces. Please help. Below is my configurations for R1 and R5:
Router1 config:
router bgp 100
no synchronization
bgp router-id 150.1.1.1
bgp log-neighbor-changes
neighbor FE80::5 remote-as 500
neighbor FE80::5 update-source Serial0/2/0
no auto-summary
!
address-family ipv6
neighbor FE80::5 activate
exit-address-family
interface Serial0/2/0
ip address 155.1.0.1 255.255.255.0
ip rip advertise 10
encapsulation frame-relay
ip split-horizon
ipv6 address FE80::1 link-local
ipv6 address 2001:1:0:1234::1/64
clock rate 2000000
frame-relay map ipv6 2001:1:0:1234::5 105 broadcast
frame-relay map ipv6 2001:1:0:1234::4 105
frame-relay map ipv6 2001:1:0:1234::3 105
frame-relay map ipv6 2001:1:0:1234::2 105
frame-relay map ip 155.1.0.5 105 broadcast
frame-relay map ip 155.1.0.4 105
frame-relay map ip 155.1.0.3 105
frame-relay map ip 155.1.0.2 105
frame-relay map ipv6 FE80::5 105
frame-relay map ipv6 FE80::4 105
frame-relay map ipv6 FE80::3 105
frame-relay map ipv6 FE80::2 105 broadcast
no frame-relay inverse-arp
end
==========================
Router5 Config
interface Serial0/0/0
ip address 155.1.0.5 255.255.255.0
ip rip advertise 10
encapsulation frame-relay
ip ospf network broadcast
ipv6 address FE80::5 link-local
ipv6 address 2001:1:0:1234::5/64
no ipv6 pim
ipv6 eigrp 100
ipv6 summary-address eigrp 100 FC00:1::/60 5
ipv6 rip 100 enable
ipv6 ospf network point-to-multipoint non-broadcast
ipv6 ospf neighbor FE80::2
ipv6 ospf neighbor FE80::3
ipv6 ospf 100 area 0
clock rate 2000000
frame-relay map ipv6 FE80::2 502 broadcast
frame-relay map ipv6 FE80::3 503 broadcast
frame-relay map ipv6 FE80::4 504 broadcast
frame-relay map ip 155.1.0.1 501 broadcast
frame-relay map ip 155.1.0.2 502 broadcast
frame-relay map ip 155.1.0.3 503 broadcast
frame-relay map ip 155.1.0.4 504 broadcast
frame-relay map ipv6 2001:1:0:1234::1 501 broadcast
frame-relay map ipv6 2001:1:0:1234::2 502 broadcast
frame-relay map ipv6 2001:1:0:1234::3 503 broadcast
frame-relay map ipv6 2001:1:0:1234::4 504 broadcast
frame-relay map ipv6 FE80::1 501 broadcast
no frame-relay inverse-arp
end
router bgp 500
no synchronization
bgp router-id 150.1.5.5
bgp log-neighbor-changes
neighbor FE80::1 remote-as 100
neighbor FE80::1 update-source Serial0/0/0
no auto-summary
!
address-family ipv6
neighbor FE80::1 activate
exit-address-family
====================================
Verification on router 1
R1#ping ipv6 fe80::5
Output Interface: Serial0/2/0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FE80::5, timeout is 2 seconds:
Packet sent with a source address of FE80::1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/5/8 ms
R1#sh bgp ipv6 unicast summ
BGP router identifier 150.1.1.1, local AS number 100
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
FE80::5 4 500 0 0 0 0 0 never Active
R1#
Verification on router 5
R5#ping fe80::1
Output Interface: serial0/0/0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FE80::1, timeout is 2 seconds:
Packet sent with a source address of FE80::5
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/3/4 ms
R5#
R5#
R5#sh bgp ipv6 uni
R5#sh bgp ipv6 unicast summ
BGP router identifier 150.1.5.5, local AS number 500
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
FE80::1 4 100 0 0 0 0 0 never Active
R5#